Loud background humming noise.

  • ...no it's not my computer, and it's not my tinnitus! it's a constant "in world" background noise. I've tried everything in sound options to turn it off but nothing works. I wonder if Cloudrise is in some sort of dome, and perhaps you could expect to hear a hum from whatever is keeping the dome there, but this is in the housing instance and open world....throughout the whole game and it's now driving me mad as silence with just the birds and lovely music would be amazing.

  • Zhirelia

    Added the Label Other
  • ...no it's not my computer, and it's not my tinnitus! it's a constant "in world" background noise. I've tried everything in sound options to turn it off but nothing works. I wonder if Cloudrise is in some sort of dome, and perhaps you could expect to hear a hum from whatever is keeping the dome there, but this is in the housing instance and open world....throughout the whole game and it's now driving me mad as silence with just the birds and lovely music would be amazing.

    Is the humming always happening, or is it only in specific locations in the world? Does it get louder in some location?


    If the answer is specific locations and yes, then it is most likely your Treasure Compass! Head to a Dragonstar (green teleport point) and Press CTRL Y and select Natural Scientist and grab the top option. This will turn it off, and the hum will go away!


    kOmFjgK.png


    You can also turn the Treasure Compass sound off in the settings:


    4OTgupl.png

  • Thanks for the reply, no, it's everywhere and nothing to do with treasure compass :/ I turned everything down completely and the humm is still there....it's like a science fiction game type of noise, the constant humming of protective shield or some such. Doesn't do it in any other game, so it's not a problem with my sound card.