Unable to pre-load beta to another disk.

  • As the title says. When attempting to install the game GF launcher gives me "folder cannot be selected as target folder" error if I pick any other disk than C. If I pick C it creates a starting folder (swords of legends online) but obviously doesn't proceed as my C disk simply has no space for the task. Will it be fixed it a near future, preferably before beta starts? I can't install it on C and it refuses to accept other disks.

  • Its a permission error for installation in this subdir what you show us.

    Install to something like D:\Games\SOLO for example.

    Same issue. I did try doing it multiple ways, including attempting to stuff it into an external hard drive.

    The thing is resolved now, for anyone having it - gameforge took offence in my user folder being not in english, works just fine on a normally-named one.

  • I'm doing some testing on this, I'll let ya know what i find.


    Edit:

    Note this affects the Gameforge client version of the game, while Steam will probably be similar there may be some differences.

    This info is not based on the Steam client.


    I ran into the issue where it kept trying to download even though i had copied the files from one source to another.

    I had copied it while at work to my laptop, then to my desktop at home.

    No matter what i did the gameforge client would try to re-download all the files again.

    So i went through to prevent the download from trying to redownload AGAIN and have it just look at the files to verify installation.


    So i checked for the registry key that would look to see if the game was up to date.

    DISCLAIMER: Modifying the registry of Windows could cause issues to your computer, modify this AT YOUR OWN RISK.

    Found the key to change it. Keep in mind the files were copied from one machine to another using a thumb drive. Permissions could be altered depending on your system settings.


    1> Create the folder on the system with what ever name you plan to use.

    2> Start the update with the settings with in the Gameforge client pointing to that folder.

    3> Allow it to start download the files to that location (for me it would take between 5-6 hours).

    4> Pause the download, then exit the Gameforge client.

    5> Copy your folders "data" and "bin64" to the Swords of Legends Online that gets created by the Gameforge client.

    6> Open the registry (regedit.exe)

    7> go to the path below (be aware of the note below it):


    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Gameforge4d\GameforgeClient\Metadata\Production\12127b3b-1ad5-493a-8d4b-caa466421d82


    Note the last string, 12127b3b-1ad5-493a-8d4b-caa466421d82, may be different on your machine.

    Select it by clicking on the numbered string in the left hand pane.


    8> There will be a key in the right hand pane listed as "GameState", if it is trying to download it will have a number higher than 5. Change this to a 1, by right clicking it and selecting modify.


    9> Restart the Gameforge client. It should show "Play".


    While i was copying the files over i started the Gameforge client early, it did not show play when files were missing.

    Once the files were finished, i changed the key back to a 1, and then it showed as Play.


    Again this is at your own risk, but if you're like me, having to wait another 5-6 hours to have access to files you already download from the Gameforge client is a bit of a pain, especially if more than one family member is going to be playing the game during the Beta weekend.


    Hope this helps some folks out, I'll see ya this weekend.


    Edit2:

    If this is an install first time, for whatever reason, select the folder twice.

    Say you go to D:\Games\SOLO

    You made the SOLO folder.

    Select it, the first time you hit install it is doing a check to make the folder is empty..

    Select it a second time with that install path (by using the browse button again).

    The second time selecting the install should start the download process.

  • My SSD doesnt have 80gb of space left so if i just click install without the browse button i get: error: insufficient space


    when i try selecting my HDD with or without any folders either nothing happens or i get error: folder cannot be selected as target folder.
    (tried every folder combination possible)


    sadly nothing so far seems to work and also xovian's approach didnt work on my pc


    hopefully there will be a fix in time before beta

  • Hey all :) I think it problem is in - "Dynamic SSD Disk" select...


    I can download SOLO "only" on "Basic SSD Disk"


    Taiwan ver can be download on "Dynamic SSD Disk"...


    I can download and instal all games from internet on "Dynamic SSD Disk" But any game from "Gameforge" Cant download on "Dynamic SSD Disk" and who know why XD


    Just error.

  • that's one hell of a risk u took there .

    to be honest i will try Edit2 and hope it works but dam man , u gone too far just to download the game !



    I tried all drivers i have on my PC aside from my C of course since i have no space there anyway , but still i always get Error message once i try to start the download .

    can i get some help over here from GM or CoMa please ?

  • .......

    that's one hell of a risk u took there .

    to be honest i will try Edit2 and hope it works but dam man , u gone too far just to download the game !

    Not really, i tend to spend a lot of time in registries on servers, since its my job.

    However, for people who arnt familiar with it (many gamers are though), there is always a risk factor clicking/changing the wrong thing ect.


    As to your issue of the dynaimic drive.

    Can you shorten the span to a much lower number between the dynamic drives (assuming you are spanning or using a software level RAID set). If you can shrink the drive by the 80+ (id say 100 if ya got it). This will release it and put it back as unallocated space. You can then reformat it, set it as a simple drive, with bottom option of the 2 choices. Set the drive letter and you should be able to make a folder and set the game to that location. You will have to select the last drive if it spanned, cant break the span, only shorten from the end of it.

    Plenty of videos out there for shrinking a drive so i wont go into the details here.


    As to why the the gameforge client refuses to work with dynamic drives, i wouldnt be able to surmise with current info we have. However this should give you a work around to be able to download.

  • Hi!

    Sorry you're all having problems with this! If you could contact Support at https://solo.support.gameforge.com/index.php?lang=en and describe the problem to them, they should be able to help and it will also help us collect information about this problem to fix it. Here's a nice guide to contacting support: [How to] Contacting the Support

    Raederle

  • Korin

    Set the Label from General to GameForge Launcher/Steam
  • Korin

    Added the Label Fixed
  • Korin

    Added the Label EN