Pre-Download Problem with Gameforge Launcher

  • I was going to attach my problem to the other two threads that are currently active but maybe creating a brand new thread, would hopefully draw more attention to this issue.

    So like Aetherblades and Vraekon's threads, I seem to have the same problem.

    Install does not seem to work in my case.

    Pressing Install simply brings the folder selection up and once I choose the folder(which has been created on a drive that has more than enough space) the window vanishes and once again displays the Install button. No matter how many times I repeat this it seems to just ignore my folder selection, the download never starts. There also is no error message displayed

    at all, it's as if I never pressed the install button:(

  • Maybe the Gameforge Client needs to be on and run from the same Disk as to where you wanna install the game?

    So like if you wanna install it on D: the Client should also be on D: and not C:

    Could someone try that, since im not able to install it on my HDD

  • Giarc Which operation system do you use?

    You can try restarting the Gameforge client by right clickling on the symbol in the Windows tray and selecting Quit, and starting it again.

    To be really sure it is fully restarted please restart your pc using the "Restart" option


    (On Windows 8.1 or higher "Shut down" does not fully shut down your pc by default, so make sure to select "Restart")

    After restart please check if the installation issue persists.

  • Restarting the PC did not fix the apparently Gameforge Client-Side problem of not accepting any other Path than

    "C:\Program Files (x86)\GameforgeClient\Swords of Legends Online"

    So everyone with a small SSD that is usually C: wont be able to download it on D:

    Atleast that's my theory

    I could start the download on my Laptop without any problem but on my PC it wont work probably because of the reasons listed above.

  • Hmm, that's probably not the issue. Or at least, not the whole issue.

    I had no problem installing the game on D: with the GF launcher in C: myself, and I'm probably not the only one. There must be something else going on.

  • Weird. I had mine download to a secondary drive just fine. Created an empty folder prior installation and selected said folder when it asked me to pick a destination. The GF client is on the main drive aswell.

    Hmm, that's probably not the issue. Or at least, not the whole issue.

    I had no problem installing the game on D: with the GF launcher in C: myself, and I'm probably not the only one. There must be something else going on.

    Thanks so far. You guys use an older launcher or did you download a fresh new for this game?

    I would really appericate a solution since Kat has so many problems alteast.

    Try using a folder name as simple as D:/SOLO. On another thread someone mentioned the GF Client didn't like non english characters. It may be that the GF Client only likes MS-DOS style folder names.

    We did and still dont want to install here. Katramis whats the error message again?

  • The folder/disk location is not the issue...

    I tried installing it on either disk (I have more than 150 gb of space on both) and neither allows me to install.

    I have contacted support and they know about this issue but could not give me any information on when the issue will be fixed.

    However, they will fix it with a patch.

    I think I will just refund the pack and maybe re-purchase it on steam since I believe steam does not have these issues...

    This is the error that pops up as soon as you press install (Show more is empty)

  • Zhirelia

    Added the Label GameForge Launcher/Steam
  • Sorry for the delay in getting back to this thread, I only came back from work a little while ago.

    Thank you for the response Korin I actually tried all this and unfortunately, it did not work, I'm on Windows 10 btw.

    So before I came back to this thread I tried out all the advice in this thread, hoping something would click for me. Nothing worked.

    I was about to give up and a miracle happened!

    My daughter walked in and said, "Dad why don't you try a VPN?"

    Initially, I ignored this since my country(South Africa) was in one of the supported regions. I could see it in Steam as well as purchase it with my local currency.

    Plus I, of course, bought it directly from the Gameforge website so yeah there should be no problem been "Blocked".

    After a little more struggle I gave up and tried a VPN as a last resort. I loaded the VPN up and logged in to the launcher, pressed the install button.....

    Yeah it worked ?(

    I'm currently downloading with a free VPN(ProtonVPN) running in the background.

    Now if I quit the launcher and turn off the VPN and then load the launcher up and log back in, it does not work no matter how many times I press that install(yes it changes back to install even when it was actually downloading with the VPN) button. If I turn on the VPN and log back in, it actually resumes downloading before I can even press anything... lol

    To be honest I don't know what is going on :/

    All I can think of is maybe the launcher is not picking up all the approved regions/countries?

    Anyway, thank you for all the advice in the thread!

  • I cannot say for Giarc.

    I know Katramis tried around 4-5 times with deinstall and install. A new folder in D: was created (D:/SOLO) - but still after pressing "install" button client says he cant use this folder.

    D: is the only way for Katramis, cause C: doesnt have enough space