Pre-Download Problem with Gameforge Launcher

  • Yes, this a launcher problem. I tried to do the same with other games and it gives the error too. The problem is, like other people here, I dont have enough space on the main drive and selecting another drive just crashes the client.
    I installed gameforge client today just for this, a friend of mine had the launcher installed before and he was able to change the directory. Dont know how to relate this but there it is.
    Still no solution.

  • I try to to this, but dont works... just getting another error.

  • I have the same problem. "Error: chosen folder is not empty". Any fix yet?

    Press the dropdown button and choose browse. Navigate to the folder where you installed your game and make sure that you selected the proper folder that has been created inside of it. It should be named "Swords of Legends Online".
    It should verify all of your game files after doing so and you'll be able to play it once it's done :)

  • So basically F for us... they dont even have time to check our problem and fix it... at this point my recomendation is just go to billing and ask for refund... we are just losing our money, losing the events and losing everything that we shop to enjoy in the beta... at this rate we gonna get the official launch without even taste any beta and lose all rewards and events from betas...

  • Korin

    Added the Label Contact Support
  • Hi,

    I have similar problem to many, when I try to install it gives the "unexpected exception" message. In the message it shows newer version of Gameforge Client than what mine (installed from the SOLO site) is. I can't find a way to update my Client.

    In the Error message it says "Gameforge Client Version:" BUT

    My Gameforge Client seems to be 2.1.32 0.4220 (from Settings->About page).

    Maybe this is a reason for the Error?

  • Same issue here, but it's now working.

    Tried all the suggestions, but the only thing that worked was trying to install on an external HD.

  • Could be the problem but I'm not 100% sure.

    You already uninstall and installed the client from the GF website?

  • Hello Guys, I hope all be fine!

    So, I got the same problem with the error and I did one thing that helped me to solver that.

    Lets for the steps:

    1 - With the gameforge launcher oppened identify correctly the folder that you selected to install the game.

    2 - Go until this folder and move the ''Swords of Legends Online'' folder for other place.

    3 - Restart the louncher.

    4 - Select the same folder that you did in the last time (certify that folder doesn't have any other in).

    5 - In the launcher, start the download of the game again.

    6 - When you see that the game started download again, you pause the game download.

    7 - Go until the folder where you are installing the game and you gonna see the ''Swords of Legends Online'' folder has created.

    8 - Delete this new folder.

    9 - Get the ''Swords of Legends Online'' folder that you moved to other place and move for the folder where the game has been installing.

    10 - Go to the launcher and change from Pause to Resume.

    If all the thing running correctly, you will see the launcher reading your last download and goes continue where you sttoped.

    I hope that it help you guys to turn download normally.

    God blass you!

    See you in the game

    by Behack_

  • Multiple times, tried even installing that one manual install installer and updating it. Nothing worked.

    EDIT. I downloaded the installer for the fifth time and let it update the game, then I tried to change my install path to my old HDD where I used to keep my games. It worked immediately.

    I tried to install it to my SSD and it would crash the Client every time.

    So it seems that it has problems with SSDs.

  • not really, at least not for me... in my case i can download the game on the SSD but i dont have enough space so i want install the game on the HDD and client crash on my HDD.

  • i tried everything every 1 been saying on the forum and no luck for me and now i missed the closed beta .

    for what did i pay money to join the closed beta i got no idea .

    even after creating 2 support tickets and mailing , no reply comes back from them after 5 days .

    can any 1 guide me what should i do in this situation ???

  • Hi. I am getting the same problem. Is this caused on the region? I know that I bought it for NA region. But in the installer, it shows EUROPE.

    Anyone getting this issue? How to change region?

  • Please have a bit patient ...

    Usually you should get an answer within 2 days but it always depens on how much tickets there are.

    Beside this Gameforge employees only work from Monday till Friday.

    Hi. I am getting the same problem. Is this caused on the region? I know that I bought it for NA region. But in the installer, it shows EUROPE.

    Anyone getting this issue? How to change region?

    Are you using the Gameforge Client or Steam?

  • I've tried everything gameforge client, unistall, reinstall, change file folder, changed pathway. Nothing works, game gets to 100% download and says unexpected error occurred with no information and makes me either delete the file in order to restart download or choose another file folder neither has worked. Restarted pc, did any and all updates. Runnin windows 10, never had issues downloading the game itself, it just fails at 100% and if I try to manually start the client through the folder i get a win dll.64 error. About to refund missed whole beta days and wasted my time trying to get this to work. Just gonna refund at this point never in 10 yrs of gaming has it been this difficult to install a damn game.

  • I even don't understand it. I uninstalled and installed the game three times and didn't get any errors.

    That's not the first own client from gameforge. Even if I'm not a great fan of such a client I never had these problems.

    (Not even during my lovely Windows Vista time lol.)

    I can understand that you want to refund the game since you couldn't test it during CB1.

    Nevertheless, may I asked you which version your client installation has (click on your username in the client, then settings, then about)?

    Did you download it from the promotion or from the Gameforge website?